p11-kit.mk 777 B

1234567891011121314151617181920212223
  1. ################################################################################
  2. #
  3. # p11-kit
  4. #
  5. ################################################################################
  6. P11_KIT_VERSION = 0.23.16.1
  7. P11_KIT_SITE = https://github.com/p11-glue/p11-kit/releases/download/$(P11_KIT_VERSION)
  8. P11_KIT_DEPENDENCIES = host-pkgconf libffi libtasn1
  9. P11_KIT_INSTALL_STAGING = YES
  10. P11_KIT_CONF_OPTS = --disable-static
  11. P11_KIT_CONF_ENV = ac_cv_have_decl_program_invocation_short_name=yes \
  12. ac_cv_have_decl___progname=no
  13. P11_KIT_LICENSE = BSD-3-Clause
  14. P11_KIT_LICENSE_FILES = COPYING
  15. ifeq ($(BR2_PACKAGE_CA_CERTIFICATES),y)
  16. P11_KIT_CONF_OPTS += --with-trust-paths=/etc/ssl/certs/ca-certificates.crt
  17. else
  18. P11_KIT_CONF_OPTS += --without-trust-paths
  19. endif
  20. $(eval $(autotools-package))