opus.mk 817 B

12345678910111213141516171819202122232425262728293031
  1. ################################################################################
  2. #
  3. # opus
  4. #
  5. ################################################################################
  6. OPUS_VERSION = 1.3.1
  7. OPUS_SITE = https://downloads.xiph.org/releases/opus
  8. OPUS_LICENSE = BSD-3-Clause
  9. OPUS_LICENSE_FILES = COPYING
  10. OPUS_INSTALL_STAGING = YES
  11. OPUS_CFLAGS = $(TARGET_CFLAGS)
  12. ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
  13. OPUS_CFLAGS += -O0
  14. endif
  15. OPUS_CONF_ENV = CFLAGS="$(OPUS_CFLAGS)"
  16. ifeq ($(BR2_PACKAGE_OPUS_FIXED_POINT),y)
  17. OPUS_CONF_OPTS += --enable-fixed-point
  18. endif
  19. # When we're on ARM, but we don't have ARM instructions (only
  20. # Thumb-2), disable the usage of assembly as it is not Thumb-ready.
  21. ifeq ($(BR2_arm)$(BR2_armeb):$(BR2_ARM_CPU_HAS_ARM),y:)
  22. OPUS_CONF_OPTS += --disable-asm
  23. endif
  24. $(eval $(autotools-package))