opkg.mk 910 B

1234567891011121314151617181920212223242526272829303132
  1. ################################################################################
  2. #
  3. # opkg
  4. #
  5. ################################################################################
  6. OPKG_VERSION = 0.4.2
  7. OPKG_SITE = http://downloads.yoctoproject.org/releases/opkg
  8. OPKG_DEPENDENCIES = host-pkgconf libarchive
  9. OPKG_LICENSE = GPL-2.0+
  10. OPKG_LICENSE_FILES = COPYING
  11. OPKG_INSTALL_STAGING = YES
  12. OPKG_CONF_OPTS = --disable-curl
  13. # Ensure directory for lockfile exists
  14. define OPKG_CREATE_LOCKDIR
  15. mkdir -p $(TARGET_DIR)/usr/lib/opkg
  16. endef
  17. ifeq ($(BR2_PACKAGE_OPKG_GPG_SIGN),y)
  18. OPKG_CONF_OPTS += --enable-gpg
  19. OPKG_CONF_ENV += \
  20. ac_cv_path_GPGME_CONFIG=$(STAGING_DIR)/usr/bin/gpgme-config \
  21. ac_cv_path_GPGERR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
  22. OPKG_DEPENDENCIES += libgpgme libgpg-error
  23. else
  24. OPKG_CONF_OPTS += --disable-gpg
  25. endif
  26. OPKG_POST_INSTALL_TARGET_HOOKS += OPKG_CREATE_LOCKDIR
  27. $(eval $(autotools-package))