openobex.mk 897 B

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # openobex
  4. #
  5. ################################################################################
  6. OPENOBEX_VERSION = 1.7.2
  7. OPENOBEX_SITE = http://downloads.sourceforge.net/project/openobex/openobex/$(OPENOBEX_VERSION)
  8. OPENOBEX_SOURCE = openobex-$(OPENOBEX_VERSION)-Source.tar.gz
  9. # Libraries seems to be released under LGPL-2.1+,
  10. # while other material is under GPL-2.0+.
  11. OPENOBEX_LICENSE = GPL-2.0+/LGPL-2.1+
  12. OPENOBEX_LICENSE_FILES = COPYING COPYING.LIB
  13. OPENOBEX_DEPENDENCIES = host-pkgconf
  14. OPENOBEX_INSTALL_STAGING = YES
  15. OPENOBEX_CONF_OPTS = -DBUILD_DOCUMENTATION=OFF
  16. ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
  17. OPENOBEX_DEPENDENCIES += bluez5_utils
  18. endif
  19. ifeq ($(BR2_PACKAGE_LIBUSB),y)
  20. OPENOBEX_DEPENDENCIES += libusb
  21. endif
  22. ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
  23. OPENOBEX_DEPENDENCIES += udev
  24. endif
  25. $(eval $(cmake-package))