odb.mk 675 B

1234567891011121314151617181920
  1. ################################################################################
  2. #
  3. # odb
  4. #
  5. ################################################################################
  6. ODB_VERSION_MAJOR = 2.4
  7. ODB_VERSION = $(ODB_VERSION_MAJOR).0
  8. ODB_SOURCE = odb-$(ODB_VERSION).tar.bz2
  9. ODB_SITE = https://www.codesynthesis.com/download/odb/$(ODB_VERSION_MAJOR)
  10. ODB_LICENSE = GPL-3.0
  11. ODB_LICENSE_FILES = LICENSE
  12. HOST_ODB_DEPENDENCIES = host-libcutl
  13. # Prevent odb from trying to install the gcc plugin into the hosts
  14. # gcc plugin directory. Instead, this will install the gcc plugin
  15. # into host/libexec/odb
  16. HOST_ODB_CONF_OPTS = --with-gcc-plugin-dir=no
  17. $(eval $(host-autotools-package))