neon.mk 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. ################################################################################
  2. #
  3. # neon
  4. #
  5. ################################################################################
  6. NEON_VERSION = 0.30.2
  7. NEON_SITE = http://www.webdav.org/neon
  8. NEON_LICENSE = LGPL-2.0+ (library), GPL-2.0+ (manual and tests)
  9. NEON_LICENSE_FILES = src/COPYING.LIB test/COPYING README
  10. NEON_INSTALL_STAGING = YES
  11. NEON_CONF_OPTS = --without-gssapi --disable-rpath
  12. NEON_CONFIG_SCRIPTS = neon-config
  13. NEON_DEPENDENCIES = host-pkgconf $(TARGET_NLS_DEPENDENCIES)
  14. NEON_CONF_ENV = ne_cv_libsfor_bindtextdomain=$(TARGET_NLS_LIBS)
  15. ifeq ($(BR2_PACKAGE_NEON_ZLIB),y)
  16. NEON_CONF_OPTS += --with-zlib=$(STAGING_DIR)
  17. NEON_DEPENDENCIES += zlib
  18. else
  19. NEON_CONF_OPTS += --without-zlib
  20. endif
  21. ifeq ($(BR2_PACKAGE_NEON_SSL),y)
  22. NEON_CONF_OPTS += --with-ssl
  23. NEON_DEPENDENCIES += openssl
  24. else
  25. NEON_CONF_OPTS += --without-ssl
  26. endif
  27. ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
  28. NEON_CONF_OPTS += --with-expat=yes
  29. NEON_DEPENDENCIES += expat
  30. else
  31. NEON_CONF_OPTS += --with-expat=no
  32. endif
  33. ifeq ($(BR2_PACKAGE_NEON_LIBXML2),y)
  34. NEON_CONF_OPTS += --with-libxml2=yes
  35. NEON_CONF_ENV += ac_cv_prog_XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
  36. NEON_DEPENDENCIES += libxml2
  37. else
  38. NEON_CONF_OPTS += --with-libxml2=no
  39. endif
  40. ifeq ($(BR2_PACKAGE_NEON_EXPAT)$(BR2_PACKAGE_NEON_LIBXML2),)
  41. # webdav needs xml support
  42. NEON_CONF_OPTS += --disable-webdav
  43. endif
  44. $(eval $(autotools-package))