ncftp.mk 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. ################################################################################
  2. #
  3. # ncftp
  4. #
  5. ################################################################################
  6. NCFTP_VERSION = 3.2.6
  7. # use .gz as upstream .xz tarball has changed after the hash was added for
  8. # 2017.02. Can be changed back to .xz when version is bumped
  9. NCFTP_SOURCE = ncftp-$(NCFTP_VERSION)-src.tar.gz
  10. NCFTP_SITE = ftp://ftp.ncftp.com/ncftp
  11. NCFTP_TARGET_BINS = ncftp
  12. NCFTP_LICENSE = Clarified Artistic License
  13. NCFTP_LICENSE_FILES = doc/LICENSE.txt
  14. NCFTP_DEPENDENCIES = host-autoconf
  15. NCFTP_CONF_OPTS = --disable-ccdv
  16. # The bundled configure script is generated by autoconf 2.13 and doesn't
  17. # detect cross-compilation correctly. Therefore, we have to regenerate it.
  18. # We need to pass -I because of the non-standard m4 directory name, and
  19. # none of the other autotools are used, so the below is the easiest.
  20. define NCFTP_RUN_AUTOCONF
  21. (cd $(@D); $(AUTOCONF) -I$(@D)/autoconf_local/)
  22. endef
  23. NCFTP_PRE_CONFIGURE_HOOKS += NCFTP_RUN_AUTOCONF
  24. ifeq ($(BR2_PACKAGE_NCFTP_GET),y)
  25. NCFTP_TARGET_BINS += ncftpget
  26. endif
  27. ifeq ($(BR2_PACKAGE_NCFTP_PUT),y)
  28. NCFTP_TARGET_BINS += ncftpput
  29. endif
  30. ifeq ($(BR2_PACKAGE_NCFTP_LS),y)
  31. NCFTP_TARGET_BINS += ncftpls
  32. endif
  33. ifeq ($(BR2_PACKAGE_NCFTP_BATCH),y)
  34. NCFTP_TARGET_BINS += ncftpbatch
  35. NCFTP_INSTALL_NCFTP_BATCH = \
  36. ln -sf /usr/bin/ncftpbatch $(TARGET_DIR)/usr/bin/ncftpspooler
  37. endif
  38. ifeq ($(BR2_PACKAGE_NCFTP_BOOKMARKS),y)
  39. NCFTP_TARGET_BINS += ncftpbookmarks
  40. NCFTP_DEPENDENCIES += ncurses
  41. endif
  42. define NCFTP_INSTALL_TARGET_CMDS
  43. $(INSTALL) -m 0755 $(addprefix $(NCFTP_DIR)/bin/, $(NCFTP_TARGET_BINS)) $(TARGET_DIR)/usr/bin
  44. $(NCFTP_INSTALL_NCFTP_BATCH)
  45. endef
  46. $(eval $(autotools-package))