msmtp.mk 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. ################################################################################
  2. #
  3. # msmtp
  4. #
  5. ################################################################################
  6. MSMTP_VERSION = 1.8.11
  7. MSMTP_SITE = https://marlam.de/msmtp/releases
  8. MSMTP_SOURCE = msmtp-$(MSMTP_VERSION).tar.xz
  9. MSMTP_DEPENDENCIES = host-pkgconf
  10. MSMTP_CONF_OPTS = --disable-gai-idn
  11. MSMTP_LICENSE = GPL-3.0+
  12. MSMTP_LICENSE_FILES = COPYING
  13. # msmtpd needs fork
  14. ifeq ($(BR2_USE_MMU),y)
  15. MSMTP_CONF_OPTS += --with-msmtpd
  16. else
  17. MSMTP_CONF_OPTS += --without-msmtpd
  18. endif
  19. ifeq ($(BR2_PACKAGE_LIBGSASL),y)
  20. MSMTP_CONF_OPTS += --with-libgsasl
  21. MSMTP_DEPENDENCIES += libgsasl
  22. else
  23. MSMTP_CONF_OPTS += --without-libgsasl
  24. endif
  25. ifeq ($(BR2_PACKAGE_LIBIDN2),y)
  26. MSMTP_CONF_OPTS += --with-libidn
  27. MSMTP_DEPENDENCIES += libidn2
  28. else
  29. MSMTP_CONF_OPTS += --without-libidn
  30. endif
  31. ifeq ($(BR2_PACKAGE_LIBSECRET),y)
  32. MSMTP_CONF_OPTS += --with-libsecret
  33. MSMTP_DEPENDENCIES += libsecret
  34. else
  35. MSMTP_CONF_OPTS += --without-libsecret
  36. endif
  37. ifeq ($(BR2_PACKAGE_GNUTLS),y)
  38. MSMTP_CONF_OPTS += --with-tls=gnutls
  39. MSMTP_DEPENDENCIES += gnutls
  40. else ifeq ($(BR2_PACKAGE_OPENSSL),y)
  41. MSMTP_CONF_OPTS += --with-tls=openssl
  42. MSMTP_DEPENDENCIES += openssl
  43. else
  44. MSMTP_CONF_OPTS += --with-tls=no
  45. endif
  46. $(eval $(autotools-package))