monit.mk 842 B

12345678910111213141516171819202122232425262728293031323334353637
  1. ################################################################################
  2. #
  3. # monit
  4. #
  5. ################################################################################
  6. MONIT_VERSION = 5.26.0
  7. MONIT_SITE = http://mmonit.com/monit/dist
  8. MONIT_LICENSE = AGPL-3.0 with OpenSSL exception
  9. MONIT_LICENSE_FILES = COPYING
  10. #
  11. # Touching Makefile.am:
  12. MONIT_AUTORECONF = YES
  13. MONIT_CONF_ENV = \
  14. libmonit_cv_setjmp_available=yes \
  15. libmonit_cv_vsnprintf_c99_conformant=yes
  16. MONIT_CONF_OPTS += \
  17. --without-pam \
  18. --with-largefiles
  19. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  20. MONIT_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
  21. MONIT_DEPENDENCIES += openssl
  22. else
  23. MONIT_CONF_OPTS += --without-ssl
  24. endif
  25. ifeq ($(BR2_PACKAGE_ZLIB),y)
  26. MONIT_CONF_OPTS += --with-zlib
  27. MONIT_DEPENDENCIES += zlib
  28. else
  29. MONIT_CONF_OPTS += --without-zlib
  30. endif
  31. $(eval $(autotools-package))