minetest-game.mk 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. ################################################################################
  2. #
  3. # minetest_game
  4. #
  5. ################################################################################
  6. MINETEST_GAME_VERSION = 5.2.0
  7. MINETEST_GAME_SITE = $(call github,minetest,minetest_game,$(MINETEST_GAME_VERSION))
  8. MINETEST_GAME_LICENSE = LGPL-2.1+ (code), CC-BY-SA-2.0, CC-BY-SA-3.0, \
  9. CC-BY-SA-4.0, MIT, CC0 1.0, CC-BY-2.0 (mods)
  10. MINETEST_GAME_LICENSE_FILES = LICENSE.txt \
  11. mods/beds/license.txt \
  12. mods/binoculars/license.txt \
  13. mods/boats/license.txt \
  14. mods/bones/license.txt \
  15. mods/bucket/license.txt \
  16. mods/butterflies/license.txt \
  17. mods/carts/license.txt \
  18. mods/creative/license.txt \
  19. mods/default/license.txt \
  20. mods/doors/license.txt \
  21. mods/dungeon_loot/license.txt \
  22. mods/dye/license.txt \
  23. mods/env_sounds/license.txt \
  24. mods/farming/license.txt \
  25. mods/fire/license.txt \
  26. mods/fireflies/license.txt \
  27. mods/flowers/license.txt \
  28. mods/game_commands/license.txt \
  29. mods/give_initial_stuff/license.txt \
  30. mods/map/license.txt \
  31. mods/player_api/license.txt \
  32. mods/screwdriver/license.txt \
  33. mods/sethome/license.txt \
  34. mods/sfinv/license.txt \
  35. mods/spawn/license.txt \
  36. mods/stairs/license.txt \
  37. mods/tnt/license.txt \
  38. mods/vessels/license.txt \
  39. mods/walls/license.txt \
  40. mods/wool/license.txt \
  41. mods/xpanes/license.txt
  42. define MINETEST_GAME_INSTALL_TARGET_CMDS
  43. mkdir -p $(TARGET_DIR)/usr/share/minetest/games/minetest_game
  44. cp -dpfr $(@D)/* $(TARGET_DIR)/usr/share/minetest/games/minetest_game
  45. endef
  46. $(eval $(generic-package))