metacity.mk 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. ################################################################################
  2. #
  3. # metacity
  4. #
  5. ################################################################################
  6. # newer versions need libcanberra-gtk and gnome-doc-utils
  7. METACITY_VERSION_MAJOR = 2.25
  8. METACITY_VERSION = $(METACITY_VERSION_MAJOR).1
  9. METACITY_SOURCE = metacity-$(METACITY_VERSION).tar.bz2
  10. METACITY_SITE = http://ftp.gnome.org/pub/gnome/sources/metacity/$(METACITY_VERSION_MAJOR)
  11. METACITY_LICENSE = GPL-2.0+
  12. METACITY_LICENSE_FILES = COPYING
  13. METACITY_CONF_OPTS = \
  14. --x-includes=$(STAGING_DIR)/usr/include/X11 \
  15. --x-libraries=$(STAGING_DIR)/usr/lib \
  16. --disable-glibtest \
  17. --disable-gconf \
  18. --disable-sm \
  19. --disable-startup-notification
  20. METACITY_DEPENDENCIES = libgtk2 \
  21. xlib_libX11 \
  22. host-libxml-parser-perl \
  23. xlib_libXcomposite \
  24. xlib_libXfixes \
  25. xlib_libXrender \
  26. xlib_libXdamage \
  27. $(TARGET_NLS_DEPENDENCIES)
  28. METACITY_CONF_ENV = LIBS=$(TARGET_NLS_LIBS)
  29. ifeq ($(BR2_PACKAGE_XLIB_LIBXCURSOR),y)
  30. METACITY_DEPENDENCIES += xlib_libXcursor
  31. endif
  32. define METACITY_INSTALL_XSESSION
  33. $(INSTALL) -D package/metacity/Xsession $(TARGET_DIR)/etc/X11/Xsession
  34. endef
  35. METACITY_POST_INSTALL_TARGET_HOOKS += METACITY_INSTALL_XSESSION
  36. $(eval $(autotools-package))