memtest86.mk 619 B

123456789101112131415161718
  1. ################################################################################
  2. #
  3. # memtest86
  4. #
  5. ################################################################################
  6. MEMTEST86_VERSION = 5.01
  7. MEMTEST86_SOURCE = memtest86+-$(MEMTEST86_VERSION).tar.gz
  8. MEMTEST86_SITE = http://www.memtest.org/download/$(MEMTEST86_VERSION)
  9. MEMTEST86_LICENSE = GPL-2.0
  10. MEMTEST86_LICENSE_FILES = README
  11. # memtest86+ is sensitive to toolchain changes, use the shipped binary version
  12. define MEMTEST86_INSTALL_TARGET_CMDS
  13. $(INSTALL) -m 0755 -D $(@D)/precomp.bin $(TARGET_DIR)/boot/memtest86+.bin
  14. endef
  15. $(eval $(generic-package))