lugaru.mk 989 B

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # lugaru
  4. #
  5. ################################################################################
  6. LUGARU_VERSION = 1.2
  7. LUGARU_SITE = https://bitbucket.org/osslugaru/lugaru/downloads
  8. LUGARU_SOURCE = lugaru-$(LUGARU_VERSION).tar.xz
  9. LUGARU_LICENSE = GPL-2.0+, CC-BY-SA-3.0 (Wolfire and Slib assets), \
  10. CC-BY-SA-4.0 (OSS Lugaru, Jendraz and Philtron R. assets)
  11. LUGARU_LICENSE_FILES = COPYING.txt CONTENT-LICENSE.txt
  12. LUGARU_DEPENDENCIES = host-pkgconf jpeg libgl libglu libpng libvorbis \
  13. openal sdl2 zlib
  14. # Avoid incompatible posix_memalign declaration on x86 and x86_64 with
  15. # musl.
  16. # https://gcc.gnu.org/ml/gcc-patches/2015-05/msg01425.html
  17. ifeq ($(BR2_TOOLCHAIN_USES_MUSL):$(BR2_i386)$(BR2_x86_64),y:y)
  18. define LUGARU_REMOVE_PEDANTIC
  19. $(SED) 's% -pedantic%%' $(@D)/CMakeLists.txt
  20. endef
  21. LUGARU_POST_PATCH_HOOKS += LUGARU_REMOVE_PEDANTIC
  22. endif
  23. LUGARU_CONF_OPTS = -DSYSTEM_INSTALL=ON
  24. $(eval $(cmake-package))