ltris.mk 876 B

1234567891011121314151617181920212223242526272829
  1. ################################################################################
  2. #
  3. # ltris
  4. #
  5. ################################################################################
  6. LTRIS_SITE = http://downloads.sourceforge.net/lgames/ltris
  7. LTRIS_VERSION = 1.2
  8. LTRIS_LICENSE = GPL-2.0+
  9. LTRIS_LICENSE_FILES = COPYING
  10. LTRIS_DEPENDENCIES = sdl $(TARGET_NLS_DEPENDENCIES)
  11. LTRIS_LIBS = $(TARGET_NLS_LIBS)
  12. LTRIS_CONF_ENV = \
  13. SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config" \
  14. LIBS="$(LTRIS_LIBS)"
  15. ifeq ($(BR2_PACKAGE_LTRIS_AUDIO),y)
  16. LTRIS_DEPENDENCIES += sdl_mixer host-pkgconf
  17. LTRIS_CONF_OPTS += --enable-sound
  18. # configure script does NOT use pkg-config to figure out how to link
  19. # with sdl_mixer, breaking static linking as sdl_mixer can use libmad
  20. LTRIS_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs SDL_mixer`
  21. else
  22. LTRIS_CONF_OPTS += --disable-sound
  23. endif
  24. $(eval $(autotools-package))