log4cpp.mk 1.2 KB

1234567891011121314151617181920212223242526272829303132333435
  1. ################################################################################
  2. #
  3. # log4cpp
  4. #
  5. ################################################################################
  6. LOG4CPP_VERSION_MAJOR = 1.1
  7. LOG4CPP_VERSION = $(LOG4CPP_VERSION_MAJOR).3
  8. LOG4CPP_SITE = http://downloads.sourceforge.net/project/log4cpp/log4cpp-1.1.x%20%28new%29/log4cpp-$(LOG4CPP_VERSION_MAJOR)
  9. LOG4CPP_SUBDIR = log4cpp
  10. # The "or later" is indicated in the HTML documentation
  11. LOG4CPP_LICENSE = LGPL-2.1+
  12. LOG4CPP_LICENSE_FILES = log4cpp/COPYING
  13. LOG4CPP_INSTALL_STAGING = YES
  14. LOG4CPP_CONF_OPTS = --enable-doxygen=no --enable-dot=no
  15. # needed to fix broken configure script
  16. LOG4CPP_AUTORECONF = YES
  17. LOG4CPP_AUTORECONF_OPTS = -I m4
  18. # The default <pkg>_CONFIG_SCRIPTS handling does not apply
  19. define LOG4CPP_STAGING_CONFIG_SCRIPT_FIXUP
  20. $(SED) 's,prefix="/usr",prefix="$(STAGING_DIR)/usr",' \
  21. -e 's,exec_prefix="/usr",prefix="$(STAGING_DIR)/usr",' \
  22. $(STAGING_DIR)/usr/bin/log4cpp-config
  23. endef
  24. LOG4CPP_POST_INSTALL_STAGING_HOOKS += LOG4CPP_STAGING_CONFIG_SCRIPT_FIXUP
  25. define LOG4CPP_TARGET_CONFIG_SCRIPT_REMOVE
  26. $(RM) $(TARGET_DIR)/usr/bin/log4cpp-config
  27. endef
  28. LOG4CPP_POST_INSTALL_TARGET_HOOKS += LOG4CPP_TARGET_CONFIG_SCRIPT_REMOVE
  29. $(eval $(autotools-package))