localedef.mk 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. ################################################################################
  2. #
  3. # localedef
  4. #
  5. ################################################################################
  6. # Use the same VERSION and SITE as target glibc
  7. # As in glibc.mk, generate version string using:
  8. # git describe --match 'glibc-*' --abbrev=40 origin/release/MAJOR.MINOR/master | cut -d '-' -f 2-
  9. LOCALEDEF_VERSION = 2.31-54-g6fdf971c9dbf7dac9bea552113fe4694015bbc4d
  10. LOCALEDEF_SOURCE = glibc-$(LOCALEDEF_VERSION).tar.gz
  11. LOCALEDEF_SITE = $(call github,bminor,glibc,$(LOCALEDEF_VERSION))
  12. HOST_LOCALEDEF_DL_SUBDIR = glibc
  13. HOST_LOCALEDEF_DEPENDENCIES = \
  14. $(BR2_MAKE_HOST_DEPENDENCY) \
  15. $(BR2_PYTHON3_HOST_DEPENDENCY) \
  16. host-bison \
  17. host-gawk
  18. HOST_LOCALEDEF_CONF_ENV += ac_cv_prog_MAKE="$(BR2_MAKE)"
  19. # Even though we use the autotools-package infrastructure, we have to override
  20. # the default configure commands for since we have to build out-of-tree, but we
  21. # can't use the same 'symbolic link to configure' used with the gcc packages.
  22. define HOST_LOCALEDEF_CONFIGURE_CMDS
  23. mkdir -p $(@D)/build
  24. # Do the configuration
  25. (cd $(@D)/build; \
  26. $(HOST_LOCALEDEF_CONF_ENV) \
  27. $(HOST_CONFIGURE_OPTS) \
  28. $(SHELL) $(@D)/configure \
  29. libc_cv_forced_unwind=yes \
  30. libc_cv_ssp=no \
  31. --target=$(GNU_HOST_NAME) \
  32. --host=$(GNU_HOST_NAME) \
  33. --build=$(GNU_HOST_NAME) \
  34. --prefix=/usr \
  35. --with-pkgversion="Buildroot" \
  36. --without-cvs \
  37. --disable-profile \
  38. --without-gd \
  39. --enable-obsolete-rpc)
  40. endef
  41. define HOST_LOCALEDEF_BUILD_CMDS
  42. $(HOST_MAKE_ENV) $(BR2_MAKE1) $(HOST_LOCALEDEF_MAKE_OPTS) \
  43. -C $(@D)/build locale/others
  44. endef
  45. # The makefile does not implement an install target for localedef
  46. define HOST_LOCALEDEF_INSTALL_CMDS
  47. $(INSTALL) -D -m 0755 $(@D)/build/locale/localedef $(HOST_DIR)/bin/localedef
  48. endef
  49. $(eval $(host-autotools-package))