linux-tool-pci.mk.in 726 B

123456789101112131415161718192021222324252627
  1. ################################################################################
  2. #
  3. # pci
  4. #
  5. ################################################################################
  6. LINUX_TOOLS += pci
  7. PCI_MAKE_OPTS = $(LINUX_MAKE_FLAGS)
  8. define PCI_BUILD_CMDS
  9. $(Q)if ! grep install $(LINUX_DIR)/tools/pci/Makefile >/dev/null 2>&1 ; then \
  10. echo "Your kernel version is too old and does not have install section in the pci tools." ; \
  11. echo "At least kernel 4.20 must be used." ; \
  12. exit 1 ; \
  13. fi
  14. $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/pci \
  15. $(PCI_MAKE_OPTS)
  16. endef
  17. define PCI_INSTALL_TARGET_CMDS
  18. $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/pci \
  19. $(PCI_MAKE_OPTS) \
  20. DESTDIR=$(TARGET_DIR) \
  21. install
  22. endef