linux-syscall-support.mk 1.0 KB

1234567891011121314151617181920212223242526272829
  1. ################################################################################
  2. #
  3. # linux-syscall-support
  4. #
  5. ################################################################################
  6. # Use the same version that the one used by Google-breakpad (see DEPS file)
  7. LINUX_SYSCALL_SUPPORT_VERSION = 3f6478ac95edf86cd3da300c2c0d34a438f5dbeb
  8. LINUX_SYSCALL_SUPPORT_SITE = https://chromium.googlesource.com/linux-syscall-support
  9. LINUX_SYSCALL_SUPPORT_SITE_METHOD = git
  10. LINUX_SYSCALL_SUPPORT_LICENSE = BSD-3-Clause
  11. LINUX_SYSCALL_SUPPORT_LICENSE_FILES = linux_syscall_support.h
  12. # Provide only one header file.
  13. LINUX_SYSCALL_SUPPORT_INSTALL_TARGET = NO
  14. LINUX_SYSCALL_SUPPORT_INSTALL_STAGING = YES
  15. define LINUX_SYSCALL_SUPPORT_INSTALL_STAGING_CMDS
  16. $(INSTALL) -D -m 0644 $(@D)/linux_syscall_support.h \
  17. $(STAGING_DIR)/usr/include/linux_syscall_support.h
  18. endef
  19. define HOST_LINUX_SYSCALL_SUPPORT_INSTALL_CMDS
  20. $(INSTALL) -D -m 0644 $(@D)/linux_syscall_support.h \
  21. $(HOST_DIR)/include/linux_syscall_support.h
  22. endef
  23. $(eval $(generic-package))
  24. $(eval $(host-generic-package))