libxslt.mk 992 B

12345678910111213141516171819202122232425262728293031323334
  1. ################################################################################
  2. #
  3. # libxslt
  4. #
  5. ################################################################################
  6. LIBXSLT_VERSION = 1.1.34
  7. LIBXSLT_SITE = http://xmlsoft.org/sources
  8. LIBXSLT_INSTALL_STAGING = YES
  9. LIBXSLT_LICENSE = MIT
  10. LIBXSLT_LICENSE_FILES = COPYING
  11. LIBXSLT_CONF_OPTS = \
  12. --with-gnu-ld \
  13. --without-debug \
  14. --without-python \
  15. --with-libxml-prefix=$(STAGING_DIR)/usr
  16. LIBXSLT_CONFIG_SCRIPTS = xslt-config
  17. LIBXSLT_DEPENDENCIES = host-pkgconf libxml2
  18. # If we have enabled libgcrypt then use it, else disable crypto support.
  19. ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
  20. LIBXSLT_DEPENDENCIES += libgcrypt
  21. LIBXSLT_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
  22. else
  23. LIBXSLT_CONF_OPTS += --without-crypto
  24. endif
  25. HOST_LIBXSLT_CONF_OPTS = --without-debug --without-python --without-crypto
  26. HOST_LIBXSLT_DEPENDENCIES = host-pkgconf host-libxml2
  27. $(eval $(autotools-package))
  28. $(eval $(host-autotools-package))