libupnp18.mk 856 B

1234567891011121314151617181920212223242526
  1. ################################################################################
  2. #
  3. # libupnp18
  4. #
  5. ################################################################################
  6. LIBUPNP18_VERSION = 1.8.7
  7. LIBUPNP18_SOURCE = libupnp-$(LIBUPNP18_VERSION).tar.bz2
  8. LIBUPNP18_SITE = http://downloads.sourceforge.net/project/pupnp/pupnp/libupnp-$(LIBUPNP18_VERSION)
  9. LIBUPNP18_CONF_ENV = ac_cv_lib_compat_ftime=no
  10. LIBUPNP18_INSTALL_STAGING = YES
  11. LIBUPNP18_LICENSE = BSD-3-Clause
  12. LIBUPNP18_LICENSE_FILES = COPYING
  13. LIBUPNP18_DEPENDENCIES = host-pkgconf
  14. # Bind the internal miniserver socket with reuseaddr to allow clean restarts.
  15. LIBUPNP18_CONF_OPTS += --enable-reuseaddr
  16. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  17. LIBUPNP18_CONF_OPTS += --enable-open-ssl
  18. LIBUPNP18_DEPENDENCIES += openssl
  19. else
  20. LIBUPNP18_CONF_OPTS += --disable-open-ssl
  21. endif
  22. $(eval $(autotools-package))