libtorrent.mk 692 B

123456789101112131415161718192021222324
  1. ################################################################################
  2. #
  3. # libtorrent
  4. #
  5. ################################################################################
  6. LIBTORRENT_VERSION = 0.13.8
  7. LIBTORRENT_SITE = http://rtorrent.net/downloads
  8. LIBTORRENT_DEPENDENCIES = host-pkgconf zlib
  9. LIBTORRENT_CONF_OPTS = --enable-aligned \
  10. --disable-instrumentation \
  11. --with-zlib=$(STAGING_DIR)/usr
  12. LIBTORRENT_INSTALL_STAGING = YES
  13. LIBTORRENT_LICENSE = GPL-2.0
  14. LIBTORRENT_LICENSE_FILES = COPYING
  15. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  16. LIBTORRENT_CONF_OPTS += --enable-openssl
  17. LIBTORRENT_DEPENDENCIES += openssl
  18. else
  19. LIBTORRENT_CONF_OPTS += --disable-openssl
  20. endif
  21. $(eval $(autotools-package))