libtorrent-rasterbar.mk 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. ################################################################################
  2. #
  3. # libtorrent-rasterbar
  4. #
  5. ################################################################################
  6. LIBTORRENT_RASTERBAR_VERSION = 1.2.7
  7. LIBTORRENT_RASTERBAR_SITE = https://github.com/arvidn/libtorrent/releases/download/libtorrent_$(subst .,_,$(LIBTORRENT_RASTERBAR_VERSION))
  8. LIBTORRENT_RASTERBAR_LICENSE = BSD-3-Clause
  9. LIBTORRENT_RASTERBAR_LICENSE_FILES = COPYING
  10. LIBTORRENT_RASTERBAR_DEPENDENCIES = host-pkgconf boost openssl
  11. LIBTORRENT_RASTERBAR_INSTALL_STAGING = YES
  12. LIBTORRENT_RASTERBAR_CONF_OPTS = \
  13. --with-boost-libdir=$(STAGING_DIR)/usr/lib \
  14. --disable-invariant-checks
  15. LIBTORRENT_RASTERBAR_CXXFLAGS = $(TARGET_CXXFLAGS) -std=c++11
  16. # Internal error, aborting at dwarf2cfi.c:2802 in connect_traces
  17. # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58864
  18. ifeq ($(BR2_m68k_cf),y)
  19. LIBTORRENT_RASTERBAR_CXXFLAGS += -fno-defer-pop
  20. endif
  21. ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
  22. LIBTORRENT_RASTERBAR_CXXFLAGS += -O0
  23. endif
  24. LIBTORRENT_RASTERBAR_CONF_OPTS += CXXFLAGS="$(LIBTORRENT_RASTERBAR_CXXFLAGS)"
  25. ifeq ($(BR2_ENABLE_LOCALE)$(BR2_PACKAGE_LIBICONV),y)
  26. LIBTORRENT_RASTERBAR_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
  27. LIBTORRENT_RASTERBAR_CONF_OPTS += --with-libiconv
  28. else
  29. LIBTORRENT_RASTERBAR_CONF_OPTS += --without-libiconv
  30. endif
  31. $(eval $(autotools-package))