libtool.mk 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. ################################################################################
  2. #
  3. # libtool
  4. #
  5. ################################################################################
  6. LIBTOOL_VERSION = 2.4.6
  7. LIBTOOL_SOURCE = libtool-$(LIBTOOL_VERSION).tar.xz
  8. LIBTOOL_SITE = $(BR2_GNU_MIRROR)/libtool
  9. # For the target variant, we only want to build/install libltdl
  10. LIBTOOL_SUBDIR = libltdl
  11. HOST_LIBTOOL_SUBDIR = .
  12. LIBTOOL_INSTALL_STAGING = YES
  13. LIBTOOL_CONF_OPTS = --enable-ltdl-install
  14. LIBTOOL_DEPENDENCIES = host-m4
  15. HOST_LIBTOOL_DEPENDENCIES = host-m4
  16. LIBTOOL_LICENSE = LGPL-2.1+
  17. LIBTOOL_LICENSE_FILES = $(LIBTOOL_SUBDIR)/COPYING.LIB
  18. HOST_LIBTOOL_LICENSE = GPL-2.0+ (libtool), LGPL-2.1+ (libltdl)
  19. HOST_LIBTOOL_LICENSE_FILES = COPYING $(LIBTOOL_SUBDIR)/COPYING.LIB
  20. HOST_LIBTOOL_CONF_ENV = MAKEINFO=true
  21. HOST_LIBTOOL_LIBTOOL_PATCH = NO
  22. # We have a patch that affects libtool.m4, which triggers an autoreconf
  23. # in the build step. Normally we would set AUTORECONF = YES, but this
  24. # doesn't work for host-libtool because that creates a circular
  25. # dependency. Instead, touch the generated files so autoreconf is not
  26. # triggered in the build step. Note that aclocal.m4 has to be touched
  27. # first since the rest depends on it. Note that we don't need the changes
  28. # in libtool.m4 in our configure script, because we're not actually
  29. # running it on the target.
  30. # For the target, we would normally be able to use AUTORECONF, but it
  31. # fails on libltdl/Makefile.inc. Rather than trying to fix that failure,
  32. # just use the same hack as on the host.
  33. define LIBTOOL_AVOID_AUTORECONF_HOOK
  34. find $(@D) -name aclocal.m4 -exec touch '{}' \;
  35. find $(@D) -name config-h.in -exec touch '{}' \;
  36. find $(@D) -name configure -exec touch '{}' \;
  37. find $(@D) -name Makefile.in -exec touch '{}' \;
  38. endef
  39. LIBTOOL_PRE_CONFIGURE_HOOKS += LIBTOOL_AVOID_AUTORECONF_HOOK
  40. HOST_LIBTOOL_PRE_CONFIGURE_HOOKS += LIBTOOL_AVOID_AUTORECONF_HOOK
  41. $(eval $(autotools-package))
  42. $(eval $(host-autotools-package))
  43. # variables used by other packages
  44. LIBTOOL = $(HOST_DIR)/bin/libtool
  45. LIBTOOLIZE = $(HOST_DIR)/bin/libtoolize