libsvgtiny.mk 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. ################################################################################
  2. #
  3. # libsvgtiny
  4. #
  5. ################################################################################
  6. LIBSVGTINY_SITE = http://git.netsurf-browser.org/libsvgtiny.git
  7. LIBSVGTINY_SITE_METHOD = git
  8. LIBSVGTINY_VERSION = ea9d99fc8b231c22d06168135e181d61f4eb2f06
  9. LIBSVGTINY_INSTALL_STAGING = YES
  10. LIBSVGTINY_DEPENDENCIES = \
  11. libxml2 host-gperf host-pkgconf host-netsurf-buildsystem
  12. LIBSVGTINY_LICENSE = MIT
  13. LIBSVGTINY_LICENSE_FILES = README
  14. # The libsvgtiny build system cannot build both the shared and static
  15. # libraries. So when the Buildroot configuration requests to build
  16. # both the shared and static variants, we build only the shared one.
  17. ifeq ($(BR2_SHARED_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
  18. LIBSVGTINY_COMPONENT_TYPE = lib-shared
  19. else
  20. LIBSVGTINY_COMPONENT_TYPE = lib-static
  21. endif
  22. define LIBSVGTINY_CONFIGURE_CMDS
  23. ln -sf $(HOST_DIR)/share/netsurf-buildsystem $(@D)/build
  24. endef
  25. # Use $(MAKE1) since parallel build fails
  26. define LIBSVGTINY_BUILD_CMDS
  27. $(TARGET_CONFIGURE_OPTS) $(MAKE1) -C $(@D) PREFIX=/usr \
  28. COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE)
  29. endef
  30. define LIBSVGTINY_INSTALL_STAGING_CMDS
  31. $(TARGET_CONFIGURE_OPTS) \
  32. $(MAKE1) -C $(@D) PREFIX=/usr DESTDIR=$(STAGING_DIR) \
  33. COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE) install
  34. endef
  35. define LIBSVGTINY_INSTALL_TARGET_CMDS
  36. $(TARGET_CONFIGURE_OPTS) \
  37. $(MAKE1) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) \
  38. COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE) install
  39. endef
  40. $(eval $(generic-package))