libsrtp.mk 1.0 KB

1234567891011121314151617181920212223242526272829303132333435
  1. ################################################################################
  2. #
  3. # libsrtp
  4. #
  5. ################################################################################
  6. LIBSRTP_VERSION = 2.2.0
  7. LIBSRTP_SITE = $(call github,cisco,libsrtp,v$(LIBSRTP_VERSION))
  8. LIBSRTP_INSTALL_STAGING = YES
  9. LIBSRTP_LICENSE = BSD-3-Clause
  10. LIBSRTP_LICENSE_FILES = LICENSE
  11. ifeq ($(BR2_STATIC_LIBS),y)
  12. LIBSRTP_MAKE_OPTS = libsrtp2.a
  13. else ifeq ($(BR2_SHARED_LIBS),y)
  14. LIBSRTP_MAKE_OPTS = shared_library
  15. else
  16. LIBSRTP_MAKE_OPTS = libsrtp2.a shared_library
  17. endif
  18. # While libsrtp is not using pkg-config itself, it checks if
  19. # pkg-config is available to determine whether it should install
  20. # libsrtp.pc. Since installing it seems useful, let's depend on
  21. # host-pkgconf to make sure pkg-config is installed.
  22. LIBSRTP_DEPENDENCIES = host-pkgconf
  23. # openssl handling needs libdl support
  24. ifeq ($(BR2_PACKAGE_OPENSSL)x$(BR2_STATIC_LIBS),yx)
  25. LIBSRTP_DEPENDENCIES += openssl
  26. LIBSRTP_CONF_OPTS += --enable-openssl
  27. else
  28. LIBSRTP_CONF_OPTS += --disable-openssl
  29. endif
  30. $(eval $(autotools-package))