libshout.mk 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. ################################################################################
  2. #
  3. # libshout
  4. #
  5. ################################################################################
  6. LIBSHOUT_VERSION = 2.4.3
  7. LIBSHOUT_SITE = https://downloads.xiph.org/releases/libshout
  8. LIBSHOUT_LICENSE = LGPL-2.0+
  9. LIBSHOUT_LICENSE_FILES = COPYING
  10. LIBSHOUT_INSTALL_STAGING = YES
  11. LIBSHOUT_DEPENDENCIES = host-pkgconf libogg libvorbis
  12. LIBSHOUT_CONF_OPTS = --disable-examples
  13. ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
  14. LIBSHOUT_CONF_OPTS += --enable-theora
  15. LIBSHOUT_DEPENDENCIES += libtheora
  16. else
  17. LIBSHOUT_CONF_OPTS += --disable-theora
  18. endif
  19. ifeq ($(BR2_PACKAGE_SPEEX),y)
  20. LIBSHOUT_CONF_OPTS += --enable-speex
  21. LIBSHOUT_DEPENDENCIES += speex
  22. else
  23. LIBSHOUT_CONF_OPTS += --disable-speex
  24. endif
  25. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  26. LIBSHOUT_CONF_OPTS += --with-openssl
  27. LIBSHOUT_DEPENDENCIES += openssl
  28. else ifeq ($(BR2_PACKAGE_LIBRESSL),y)
  29. LIBSHOUT_CONF_OPTS += --with-openssl=$(STAGING_DIR)/lib
  30. LIBSHOUT_DEPENDENCIES += libressl
  31. else
  32. LIBSHOUT_CONF_OPTS += --without-openssl
  33. endif
  34. $(eval $(autotools-package))