libsecret.mk 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. ################################################################################
  2. #
  3. # libsecret
  4. #
  5. ################################################################################
  6. LIBSECRET_VERSION_MAJOR = 0.20
  7. LIBSECRET_VERSION = $(LIBSECRET_VERSION_MAJOR).3
  8. LIBSECRET_SITE = http://ftp.gnome.org/pub/GNOME/sources/libsecret/$(LIBSECRET_VERSION_MAJOR)
  9. LIBSECRET_SOURCE = libsecret-$(LIBSECRET_VERSION).tar.xz
  10. LIBSECRET_INSTALL_STAGING = YES
  11. LIBSECRET_DEPENDENCIES = libglib2 $(TARGET_NLS_DEPENDENCIES)
  12. LIBSECRET_CONF_ENV = LIBS=$(TARGET_NLS_LIBS)
  13. LIBSECRET_CONF_OPTS = \
  14. --disable-manpages \
  15. --disable-strict \
  16. --disable-coverage \
  17. --enable-vala=no
  18. LIBSECRET_LICENSE = LGPL-2.1+
  19. LIBSECRET_LICENSE_FILES = COPYING
  20. ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
  21. LIBSECRET_CONF_OPTS += --enable-introspection=yes
  22. LIBSECRET_DEPENDENCIES += gobject-introspection
  23. else
  24. LIBSECRET_CONF_OPTS += --enable-introspection=no
  25. endif
  26. ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
  27. LIBSECRET_DEPENDENCIES += libgcrypt
  28. LIBSECRET_CONF_OPTS += --enable-gcrypt \
  29. --with-libgcrypt-prefix=$(STAGING_DIR)/usr
  30. else
  31. LIBSECRET_CONF_OPTS += --disable-gcrypt
  32. endif
  33. $(eval $(autotools-package))