libpam-nfc.mk 726 B

12345678910111213141516171819202122
  1. ################################################################################
  2. #
  3. # libpam-nfc
  4. #
  5. ################################################################################
  6. LIBPAM_NFC_VERSION = bb762e0e649195110e015ffb605c4375e927c437
  7. LIBPAM_NFC_SITE = $(call github,nfc-tools,pam_nfc,$(LIBPAM_NFC_VERSION))
  8. LIBPAM_NFC_LICENSE = GPL-2.0
  9. LIBPAM_NFC_LICENSE_FILES = COPYING
  10. LIBPAM_NFC_DEPENDENCIES = linux-pam libnfc
  11. # Fetching from github, we need to generate the configure script
  12. LIBPAM_NFC_AUTORECONF = YES
  13. LIBPAM_NFC_INSTALL_STAGING = YES
  14. LIBPAM_NFC_CONF_OPTS = \
  15. --with-pam-dir=/lib/security
  16. # libpam breaks with parallel build, but is very fast to build.
  17. LIBPAM_NFC_MAKE = $(MAKE1)
  18. $(eval $(autotools-package))