libp11.mk 887 B

1234567891011121314151617181920212223242526
  1. ################################################################################
  2. #
  3. # libp11
  4. #
  5. ################################################################################
  6. LIBP11_VERSION = 0.4.10
  7. LIBP11_SITE = https://github.com/OpenSC/libp11/releases/download/libp11-$(LIBP11_VERSION)
  8. LIBP11_DEPENDENCIES = openssl host-pkgconf
  9. LIBP11_INSTALL_STAGING = YES
  10. LIBP11_LICENSE = LGPL-2.1+
  11. LIBP11_LICENSE_FILES = COPYING
  12. # pkg-config returns a libcrypto enginesdir prefixed with the sysroot,
  13. # so let's rip it out.
  14. LIBP11_CONF_OPTS = \
  15. --with-enginesdir=`$(PKG_CONFIG_HOST_BINARY) --variable enginesdir libcrypto | xargs readlink -f | sed 's%^$(STAGING_DIR)%%'`
  16. ifeq ($(BR2_PACKAGE_P11_KIT),y)
  17. LIBP11_CONF_OPTS += --with-pkcs11-module=/usr/lib/p11-kit-proxy.so
  18. endif
  19. HOST_LIBP11_DEPENDENCIES = host-pkgconf host-openssl
  20. $(eval $(autotools-package))
  21. $(eval $(host-autotools-package))