libostree.mk 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. ################################################################################
  2. #
  3. # libostree
  4. #
  5. ################################################################################
  6. LIBOSTREE_VERSION = 2020.6
  7. LIBOSTREE_SOURCE = libostree-$(LIBOSTREE_VERSION).tar.xz
  8. LIBOSTREE_SITE = https://github.com/ostreedev/ostree/releases/download/v$(LIBOSTREE_VERSION)
  9. LIBOSTREE_LICENSE = LGPL-2.0+
  10. LIBOSTREE_LICENSE_FILES = COPYING
  11. LIBOSTREE_DEPENDENCIES = e2fsprogs host-bison host-pkgconf libfuse libglib2 libgpg-error libgpgme xz
  12. LIBOSTREE_INSTALL_STAGING = YES
  13. LIBOSTREE_CONF_ENV = \
  14. GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
  15. LIBOSTREE_CONF_OPTS += \
  16. --with-gpgme-prefix=$(STAGING_DIR)/usr \
  17. --disable-gtk-doc \
  18. --disable-gtk-doc-html \
  19. --disable-gtk-doc-pdf \
  20. --disable-man
  21. ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
  22. LIBOSTREE_DEPENDENCIES += gobject-introspection
  23. LIBOSTREE_CONF_OPTS += --enable-introspection
  24. LIBOSTREE_MAKE_OPTS = INTROSPECTION_SCANNER_ENV=
  25. else
  26. LIBOSTREE_CONF_OPTS += --disable-introspection
  27. endif
  28. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  29. LIBOSTREE_CONF_OPTS += --with-openssl
  30. LIBOSTREE_DEPENDENCIES += openssl
  31. else
  32. LIBOSTREE_CONF_OPTS += --without-openssl
  33. endif
  34. # Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
  35. # and dbus is selected. Since there is no BR2_PACKAGE_LIBAVAHI_CLIENT config
  36. # option yet, use the avahi-daemon and dbus config symbols to check for
  37. # libavahi-client.
  38. ifeq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_DBUS),yy)
  39. LIBOSTREE_CONF_OPTS += --with-avahi
  40. LIBOSTREE_DEPENDENCIES += avahi
  41. else
  42. LIBOSTREE_CONF_OPTS += --without-avahi
  43. endif
  44. #cURL support depends on libsoup
  45. ifeq ($(BR2_PACKAGE_LIBSOUP),y)
  46. LIBOSTREE_CONF_OPTS += --with-soup
  47. LIBOSTREE_DEPENDENCIES += libsoup
  48. ifeq ($(BR2_PACKAGE_LIBCURL),y)
  49. LIBOSTREE_CONF_OPTS += --with-curl
  50. LIBOSTREE_DEPENDENCIES += libcurl
  51. else
  52. LIBOSTREE_CONF_OPTS += --without-curl
  53. endif
  54. else
  55. LIBOSTREE_CONF_OPTS += --without-soup --without-curl
  56. endif
  57. ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)
  58. LIBOSTREE_CONF_OPTS += --with-libarchive
  59. LIBOSTREE_DEPENDENCIES += libarchive
  60. else
  61. LIBOSTREE_CONF_OPTS += --without-libarchive
  62. endif
  63. ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
  64. LIBOSTREE_CONF_OPTS += --with-selinux
  65. LIBOSTREE_DEPENDENCIES += libselinux
  66. else
  67. LIBOSTREE_CONF_OPTS += --without-selinux
  68. endif
  69. ifeq ($(BR2_INIT_SYSTEMD),y)
  70. LIBOSTREE_CONF_OPTS += \
  71. --with-libsystemd \
  72. --with-systemdsystemunitdir=/usr/lib/systemd/system
  73. LIBOSTREE_DEPENDENCIES += systemd
  74. else
  75. LIBOSTREE_CONF_OPTS += --without-libsystemd
  76. endif
  77. $(eval $(autotools-package))