libnl.mk 727 B

123456789101112131415161718192021222324252627
  1. ################################################################################
  2. #
  3. # libnl
  4. #
  5. ################################################################################
  6. LIBNL_VERSION = 3.5.0
  7. LIBNL_SITE = https://github.com/thom311/libnl/releases/download/libnl$(subst .,_,$(LIBNL_VERSION))
  8. LIBNL_LICENSE = LGPL-2.1+
  9. LIBNL_LICENSE_FILES = COPYING
  10. LIBNL_INSTALL_STAGING = YES
  11. LIBNL_DEPENDENCIES = host-bison host-flex host-pkgconf
  12. ifeq ($(BR2_PACKAGE_LIBNL_TOOLS),y)
  13. LIBNL_CONF_OPTS += --enable-cli
  14. else
  15. LIBNL_CONF_OPTS += --disable-cli
  16. endif
  17. ifeq ($(BR2_PACKAGE_CHECK),y)
  18. LIBNL_DEPENDENCIES += check
  19. LIBNL_CONF_OPTS += --enable-unit-tests
  20. else
  21. LIBNL_CONF_OPTS += --disable-unit-tests
  22. endif
  23. $(eval $(autotools-package))