libnids.mk 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. ################################################################################
  2. #
  3. # libnids
  4. #
  5. ################################################################################
  6. LIBNIDS_VERSION = 1.24
  7. LIBNIDS_SITE = https://sourceforge.net/projects/libnids/files/libnids/$(LIBNIDS_VERSION)
  8. LIBNIDS_LICENSE = GPL-2.0
  9. LIBNIDS_LICENSE_FILES = COPYING
  10. LIBNIDS_INSTALL_STAGING = YES
  11. LIBNIDS_DEPENDENCIES = host-pkgconf libpcap
  12. LIBNIDS_AUTORECONF = YES
  13. # CVE-2010-0751 was fixed in libnids v1.24 but the NVD database is not
  14. # aware of the fix, ignore it until this is updated
  15. LIBNIDS_IGNORE_CVES += CVE-2010-0751
  16. # disable libnet if not available
  17. # Tests in configure.in expect --with-libnet=$build_dir
  18. # not an installation patch like in our context.
  19. # We use with-libnet=yes to skip the unusual paths tests.
  20. # But 'LNETLIB' gets left out, so we need to define it ourselves.
  21. ifeq ($(BR2_PACKAGE_LIBNET),y)
  22. LIBNIDS_DEPENDENCIES += libnet
  23. LIBNIDS_CONF_OPTS += --enable-libnet --with-libnet=yes LNETLIB=-lnet
  24. else
  25. LIBNIDS_CONF_OPTS += --disable-libnet
  26. endif
  27. # disable libglib2 if not available
  28. # The test in configure.in is flawed: passing --enable-libglib would also
  29. # disable it. Only when neither is passed will the autodetection test be
  30. # executed.
  31. ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
  32. LIBNIDS_DEPENDENCIES += libglib2
  33. else
  34. LIBNIDS_CONF_OPTS += --disable-libglib
  35. endif
  36. # hand-written Makefile.in, not using automake, needs a custom
  37. # variable for the installation path.
  38. LIBNIDS_INSTALL_STAGING_OPTS = install_prefix=$(STAGING_DIR) install
  39. LIBNIDS_INSTALL_TARGET_OPTS = install_prefix=$(TARGET_DIR) install
  40. $(eval $(autotools-package))