liblog4c-localtime.mk 808 B

1234567891011121314151617181920212223
  1. ################################################################################
  2. #
  3. # liblog4c-localtime
  4. #
  5. ################################################################################
  6. LIBLOG4C_LOCALTIME_VERSION = 1.0
  7. LIBLOG4C_LOCALTIME_SITE = $(call github,rcmadruga,log4c-localtime,v$(LIBLOG4C_LOCALTIME_VERSION))
  8. LIBLOG4C_LOCALTIME_INSTALL_STAGING = YES
  9. LIBLOG4C_LOCALTIME_CONF_OPTS = --disable-expattest
  10. LIBLOG4C_LOCALTIME_DEPENDENCIES = expat
  11. LIBLOG4C_LOCALTIME_CONFIG_SCRIPTS = log4c-config
  12. LIBLOG4C_LOCALTIME_LICENSE = LGPL-2.1
  13. LIBLOG4C_LOCALTIME_LICENSE_FILES = COPYING
  14. LIBLOG4C_LOCALTIME_AUTORECONF = YES
  15. define LIBLOG4C_LOCALTIME_FIX_CONFIGURE_PERMS
  16. chmod +x $(@D)/configure
  17. endef
  18. LIBLOG4C_LOCALTIME_PRE_CONFIGURE_HOOKS += LIBLOG4C_LOCALTIME_FIX_CONFIGURE_PERMS
  19. $(eval $(autotools-package))