libldns.mk 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. ################################################################################
  2. #
  3. # libldns
  4. #
  5. ################################################################################
  6. LIBLDNS_VERSION = 1.7.1
  7. LIBLDNS_SOURCE = ldns-$(LIBLDNS_VERSION).tar.gz
  8. LIBLDNS_SITE = http://www.nlnetlabs.nl/downloads/ldns
  9. LIBLDNS_LICENSE = BSD-3-Clause
  10. LIBLDNS_LICENSE_FILES = LICENSE
  11. LIBLDNS_INSTALL_STAGING = YES
  12. LIBLDNS_DEPENDENCIES = openssl
  13. # --disable-dane-verify can be removed after openssl bump to 1.1.x
  14. LIBLDNS_CONF_OPTS = \
  15. --with-ssl=$(STAGING_DIR)/usr \
  16. --enable-dane \
  17. --disable-dane-verify \
  18. --enable-ecdsa \
  19. --enable-gost \
  20. --enable-sha2 \
  21. --without-examples \
  22. --without-p5-dns-ldns \
  23. --without-pyldns \
  24. --without-pyldnsx
  25. ifeq ($(BR2_STATIC_LIBS),y)
  26. LIBLDNS_DEPENDENCIES += host-pkgconf
  27. # missing -lz breaks configure, add it using pkgconf
  28. LIBLDNS_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs openssl`"
  29. endif
  30. # the linktest make target fails with static linking, and we are only
  31. # interested in the lib target anyway
  32. LIBLDNS_MAKE_OPTS = lib
  33. $(eval $(autotools-package))