libiconv.mk 1.2 KB

1234567891011121314151617181920212223242526272829303132
  1. ################################################################################
  2. #
  3. # libiconv
  4. #
  5. ################################################################################
  6. LIBICONV_VERSION = 1.15
  7. LIBICONV_SITE = $(BR2_GNU_MIRROR)/libiconv
  8. LIBICONV_INSTALL_STAGING = YES
  9. LIBICONV_LICENSE = GPL-3.0+ (iconv program), LGPL-2.0+ (library)
  10. LIBICONV_LICENSE_FILES = COPYING COPYING.LIB
  11. ifeq ($(BR2_PACKAGE_LIBICONV_EXTRA_ENCODINGS),y)
  12. LIBICONV_CONF_OPTS = --enable-extra-encodings
  13. endif
  14. # Don't build the preloadable library, as we don't need it (it's only
  15. # for LD_PRELOAD to replace glibc's iconv, but we never build libiconv
  16. # when glibc is used). And it causes problems for static only builds.
  17. define LIBICONV_DISABLE_PRELOAD
  18. $(SED) '/preload/d' $(@D)/Makefile.in
  19. endef
  20. LIBICONV_PRE_CONFIGURE_HOOKS += LIBICONV_DISABLE_PRELOAD
  21. $(eval $(autotools-package))
  22. # Configurations where the toolchain supports locales and the libiconv
  23. # package is enabled are incorrect, because the toolchain already
  24. # provides libiconv functionality, and having both confuses packages.
  25. ifeq ($(BR2_PACKAGE_LIBICONV)$(BR2_ENABLE_LOCALE),yy)
  26. $(error Libiconv should never be enabled when the toolchain supports locales. Report this failure to Buildroot developers)
  27. endif