libgeotiff.mk 759 B

12345678910111213141516171819202122232425262728
  1. ################################################################################
  2. #
  3. # libgeotiff
  4. #
  5. ################################################################################
  6. LIBGEOTIFF_VERSION = 1.6.0
  7. LIBGEOTIFF_SITE = http://download.osgeo.org/geotiff/libgeotiff
  8. LIBGEOTIFF_LICENSE = X11-style, public domain
  9. LIBGEOTIFF_LICENSE_FILES = LICENSE
  10. LIBGEOTIFF_DEPENDENCIES = proj tiff host-pkgconf
  11. LIBGEOTIFF_INSTALL_STAGING = YES
  12. ifeq ($(BR2_PACKAGE_ZLIB),y)
  13. LIBGEOTIFF_DEPENDENCIES += zlib
  14. LIBGEOTIFF_CONF_OPTS += --with-zlib
  15. else
  16. LIBGEOTIFF_CONF_OPTS += --without-zlib
  17. endif
  18. ifeq ($(BR2_PACKAGE_JPEG),y)
  19. LIBGEOTIFF_DEPENDENCIES += jpeg
  20. LIBGEOTIFF_CONF_OPTS += --with-jpeg
  21. else
  22. LIBGEOTIFF_CONF_OPTS += --without-jpeg
  23. endif
  24. $(eval $(autotools-package))