libgcrypt.mk 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. ################################################################################
  2. #
  3. # libgcrypt
  4. #
  5. ################################################################################
  6. LIBGCRYPT_VERSION = 1.8.6
  7. LIBGCRYPT_SOURCE = libgcrypt-$(LIBGCRYPT_VERSION).tar.bz2
  8. LIBGCRYPT_LICENSE = LGPL-2.1+
  9. LIBGCRYPT_LICENSE_FILES = COPYING.LIB
  10. LIBGCRYPT_SITE = https://gnupg.org/ftp/gcrypt/libgcrypt
  11. LIBGCRYPT_INSTALL_STAGING = YES
  12. LIBGCRYPT_DEPENDENCIES = libgpg-error
  13. LIBGCRYPT_CONFIG_SCRIPTS = libgcrypt-config
  14. # Patching acinclude.m4 in 0001
  15. # Patching configure.ac and Makefile.am in 0002
  16. LIBGCRYPT_AUTORECONF = YES
  17. LIBGCRYPT_CONF_OPTS = \
  18. --disable-tests \
  19. --with-gpg-error-prefix=$(STAGING_DIR)/usr
  20. # Libgcrypt doesn't support assembly for coldfire
  21. ifeq ($(BR2_m68k_cf),y)
  22. LIBGCRYPT_CONF_OPTS += --disable-asm
  23. endif
  24. # Code doesn't build in thumb mode
  25. ifeq ($(BR2_arm),y)
  26. LIBGCRYPT_CONF_ENV += CFLAGS="$(patsubst -mthumb,,$(TARGET_CFLAGS))"
  27. endif
  28. # Tests use fork()
  29. define LIBGCRYPT_DISABLE_TESTS
  30. $(SED) 's/ tests//' $(@D)/Makefile.in
  31. endef
  32. LIBGCRYPT_POST_PATCH_HOOKS += LIBGCRYPT_DISABLE_TESTS
  33. $(eval $(autotools-package))