libfuse.mk 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. ################################################################################
  2. #
  3. # libfuse
  4. #
  5. ################################################################################
  6. LIBFUSE_VERSION = 2.9.9
  7. LIBFUSE_SOURCE = fuse-$(LIBFUSE_VERSION).tar.gz
  8. LIBFUSE_SITE = https://github.com/libfuse/libfuse/releases/download/fuse-$(LIBFUSE_VERSION)
  9. LIBFUSE_LICENSE = GPL-2.0, LGPL-2.1
  10. LIBFUSE_LICENSE_FILES = COPYING COPYING.LIB
  11. LIBFUSE_INSTALL_STAGING = YES
  12. LIBFUSE_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
  13. LIBFUSE_CONF_OPTS = \
  14. --disable-example \
  15. --enable-lib \
  16. --enable-util \
  17. UDEV_RULES_PATH=/lib/udev/rules.d
  18. ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
  19. define LIBFUSE_INSTALL_UDEV
  20. mkdir -p $(TARGET_DIR)/lib/udev/rules.d
  21. cp $(STAGING_DIR)/lib/udev/rules.d/*-fuse.rules $(TARGET_DIR)/lib/udev/rules.d
  22. endef
  23. LIBFUSE_POST_INSTALL_TARGET_HOOKS += LIBFUSE_INSTALL_UDEV
  24. endif
  25. define LIBFUSE_INSTALL_TARGET_CMDS
  26. cp -dpf $(STAGING_DIR)/usr/bin/fusermount $(TARGET_DIR)/usr/bin/
  27. cp -dpf $(STAGING_DIR)/usr/lib/libfuse.so* $(TARGET_DIR)/usr/lib/
  28. endef
  29. define LIBFUSE_DEVICES
  30. /dev/fuse c 666 0 0 10 229 0 0 -
  31. endef
  32. define LIBFUSE_PERMISSIONS
  33. /usr/bin/fusermount f 4755 0 0 - - - - -
  34. endef
  35. $(eval $(autotools-package))