libevent.mk 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. ################################################################################
  2. #
  3. # libevent
  4. #
  5. ################################################################################
  6. LIBEVENT_VERSION = 2.1.12
  7. LIBEVENT_SITE = https://github.com/libevent/libevent/releases/download/release-$(LIBEVENT_VERSION)-stable
  8. LIBEVENT_SOURCE = libevent-$(LIBEVENT_VERSION)-stable.tar.gz
  9. LIBEVENT_INSTALL_STAGING = YES
  10. LIBEVENT_LICENSE = BSD-3-Clause, OpenBSD
  11. LIBEVENT_LICENSE_FILES = LICENSE
  12. LIBEVENT_CONF_OPTS = \
  13. --disable-libevent-regress \
  14. --disable-samples
  15. HOST_LIBEVENT_CONF_OPTS = \
  16. --disable-libevent-regress \
  17. --disable-samples \
  18. --disable-openssl
  19. define LIBEVENT_REMOVE_PYSCRIPT
  20. rm $(TARGET_DIR)/usr/bin/event_rpcgen.py
  21. endef
  22. # libevent installs a python script to target - get rid of it if we
  23. # don't have python support enabled
  24. ifneq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
  25. LIBEVENT_POST_INSTALL_TARGET_HOOKS += LIBEVENT_REMOVE_PYSCRIPT
  26. endif
  27. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  28. LIBEVENT_DEPENDENCIES += host-pkgconf openssl
  29. LIBEVENT_CONF_OPTS += --enable-openssl
  30. else
  31. LIBEVENT_CONF_OPTS += --disable-openssl
  32. endif
  33. $(eval $(autotools-package))
  34. $(eval $(host-autotools-package))