libev.mk 668 B

123456789101112131415161718192021
  1. ################################################################################
  2. #
  3. # libev
  4. #
  5. ################################################################################
  6. LIBEV_VERSION = 4.27
  7. LIBEV_SITE = http://dist.schmorp.de/libev/Attic
  8. LIBEV_INSTALL_STAGING = YES
  9. LIBEV_LICENSE = BSD-2-Clause or GPL-2.0+
  10. LIBEV_LICENSE_FILES = LICENSE
  11. # The 'compatibility' event.h header conflicts with libevent
  12. # It's completely unnecessary for BR packages so remove it
  13. define LIBEV_DISABLE_EVENT_H_INSTALL
  14. $(SED) 's/ event.h//' $(@D)/Makefile.in
  15. endef
  16. LIBEV_POST_PATCH_HOOKS += LIBEV_DISABLE_EVENT_H_INSTALL
  17. $(eval $(autotools-package))
  18. $(eval $(host-autotools-package))