libedit.mk 923 B

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # libedit
  4. #
  5. ################################################################################
  6. LIBEDIT_VERSION = 20190324-3.1
  7. LIBEDIT_SITE = http://www.thrysoee.dk/editline
  8. LIBEDIT_INSTALL_STAGING = YES
  9. LIBEDIT_DEPENDENCIES = ncurses
  10. LIBEDIT_LICENSE = BSD-3-Clause
  11. LIBEDIT_LICENSE_FILES = COPYING
  12. # We're patching configure.ac
  13. LIBEDIT_AUTORECONF = YES
  14. # musl is ISO 10646 compliant but doesn't define __STDC_ISO_10646__,
  15. # so let's define it manually
  16. ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
  17. LIBEDIT_CONF_OPTS += CFLAGS="$(TARGET_CFLAGS) -D__STDC_ISO_10646__=201103L"
  18. endif
  19. # Note: libbsd required for *vis functions, but works only with a toolchain
  20. # with __progname; otherwise, some features are disabled, as if libbsd was
  21. # missing entirely.
  22. ifeq ($(BR2_PACKAGE_LIBBSD),y)
  23. LIBEDIT_DEPENDENCIES += libbsd
  24. endif
  25. $(eval $(autotools-package))