libcdio.mk 735 B

1234567891011121314151617181920212223242526272829
  1. ################################################################################
  2. #
  3. # libcdio
  4. #
  5. ################################################################################
  6. LIBCDIO_VERSION = 2.1.0
  7. LIBCDIO_SOURCE = libcdio-$(LIBCDIO_VERSION).tar.bz2
  8. LIBCDIO_SITE = $(BR2_GNU_MIRROR)/libcdio
  9. LIBCDIO_INSTALL_STAGING = YES
  10. LIBCDIO_LICENSE = GPL-3.0+
  11. LIBCDIO_LICENSE_FILES = COPYING
  12. LIBCDIO_CONF_OPTS = --disable-example-progs --disable-cddb
  13. ifeq ($(BR2_ENABLE_LOCALE),)
  14. LIBCDIO_DEPENDENCIES += libiconv
  15. endif
  16. ifeq ($(BR2_INSTALL_LIBSTDCPP),)
  17. LIBCDIO_CONF_OPTS += --disable-cxx
  18. endif
  19. ifeq ($(BR2_PACKAGE_NCURSES),y)
  20. LIBCDIO_DEPENDENCIES += ncurses
  21. else
  22. LIBCDIO_CONF_OPTS += --without-cdda-player
  23. endif
  24. $(eval $(autotools-package))