libbson.mk 673 B

123456789101112131415161718192021
  1. ################################################################################
  2. #
  3. # libbson
  4. #
  5. ################################################################################
  6. LIBBSON_VERSION = 1.9.5
  7. LIBBSON_SITE = https://github.com/mongodb/libbson/releases/download/$(LIBBSON_VERSION)
  8. LIBBSON_LICENSE = Apache-2.0, MIT (jsonl), ISC (b64), Zlib (md5)
  9. LIBBSON_LICENSE_FILES = COPYING THIRD_PARTY_NOTICES
  10. LIBBSON_CONF_OPTS = \
  11. --disable-tests \
  12. --disable-examples \
  13. --disable-man-pages \
  14. --disable-html-docs
  15. LIBBSON_INSTALL_STAGING = YES
  16. # Also has CMake support, but that forces shared+static libs and static
  17. # lib has a different name.
  18. $(eval $(autotools-package))