libatomic_ops.mk 1.0 KB

123456789101112131415161718192021222324252627
  1. ################################################################################
  2. #
  3. # libatomic_ops
  4. #
  5. ################################################################################
  6. LIBATOMIC_OPS_VERSION = 7.6.10
  7. LIBATOMIC_OPS_SITE = $(call github,ivmai,libatomic_ops,v$(LIBATOMIC_OPS_VERSION))
  8. LIBATOMIC_OPS_AUTORECONF = YES
  9. # From doc/LICENSING.txt: "Our intent is to make it easy to use
  10. # libatomic_ops, in both free and proprietary software. Hence most
  11. # code that we expect to be linked into a client application is
  12. # covered by an MIT-style license. A few library routines are covered
  13. # by the GNU General Public License. These are put into a separate
  14. # library, libatomic_ops_gpl.a."
  15. LIBATOMIC_OPS_LICENSE = MIT (main library) / GPL-2.0+ (gpl extension)
  16. LIBATOMIC_OPS_LICENSE_FILES = doc/LICENSING.txt COPYING
  17. LIBATOMIC_OPS_INSTALL_STAGING = YES
  18. ifeq ($(BR2_sparc_v8)$(BR2_sparc_leon3),y)
  19. LIBATOMIC_OPS_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DAO_NO_SPARC_V9"
  20. endif
  21. $(eval $(autotools-package))
  22. $(eval $(host-autotools-package))