libass.mk 1.0 KB

1234567891011121314151617181920212223242526272829303132333435
  1. ################################################################################
  2. #
  3. # libass
  4. #
  5. ################################################################################
  6. LIBASS_VERSION = 0.15.0
  7. LIBASS_SOURCE = libass-$(LIBASS_VERSION).tar.xz
  8. # Do not use the github helper here, the generated tarball is *NOT*
  9. # the same as the one uploaded by upstream for the release.
  10. LIBASS_SITE = https://github.com/libass/libass/releases/download/$(LIBASS_VERSION)
  11. LIBASS_INSTALL_STAGING = YES
  12. LIBASS_LICENSE = ISC
  13. LIBASS_LICENSE_FILES = COPYING
  14. LIBASS_DEPENDENCIES = \
  15. host-pkgconf \
  16. freetype \
  17. harfbuzz \
  18. libfribidi \
  19. $(if $(BR2_PACKAGE_LIBICONV),libiconv)
  20. # configure: WARNING: Install nasm for a significantly faster libass build.
  21. # only for Intel archs
  22. ifeq ($(BR2_i386)$(BR2_x86_64),y)
  23. LIBASS_DEPENDENCIES += host-nasm
  24. endif
  25. ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
  26. LIBASS_DEPENDENCIES += fontconfig
  27. LIBASS_CONF_OPTS += --enable-fontconfig
  28. else
  29. LIBASS_CONF_OPTS += --disable-fontconfig --disable-require-system-font-provider
  30. endif
  31. $(eval $(autotools-package))