libao.mk 913 B

12345678910111213141516171819202122232425262728293031323334
  1. ################################################################################
  2. #
  3. # libao
  4. #
  5. ################################################################################
  6. LIBAO_VERSION = 1.2.0
  7. LIBAO_SITE = http://downloads.xiph.org/releases/ao
  8. LIBAO_DEPENDENCIES = host-pkgconf
  9. LIBAO_INSTALL_STAGING = YES
  10. LIBAO_LICENSE = GPL-2.0+
  11. LIBAO_LICENSE_FILES = COPYING
  12. LIBAO_CONF_OPTS = \
  13. --disable-esd \
  14. --disable-wmm \
  15. --disable-arts \
  16. --disable-nas \
  17. --disable-pulse \
  18. --disable-broken-oss
  19. ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
  20. LIBAO_DEPENDENCIES += alsa-lib
  21. LIBAO_CONF_OPTS += --enable-alsa --enable-alsa-mmap
  22. # Remove the OSS plugin if ALSA is enabled, as libao will prefer ALSA anyway
  23. define LIBAO_REMOVE_OSS_PLUGIN
  24. rm -f $(TARGET_DIR)/usr/lib/ao/plugins-4/liboss.so
  25. endef
  26. LIBAO_POST_INSTALL_TARGET_HOOKS += LIBAO_REMOVE_OSS_PLUGIN
  27. else
  28. LIBAO_CONF_OPTS += --disable-alsa
  29. endif
  30. $(eval $(autotools-package))