lesstif.mk 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. ################################################################################
  2. #
  3. # lesstif
  4. #
  5. ################################################################################
  6. LESSTIF_VERSION = 0.95.2
  7. LESSTIF_SOURCE = lesstif-$(LESSTIF_VERSION).tar.bz2
  8. LESSTIF_SITE = http://downloads.sourceforge.net/project/lesstif/lesstif/$(LESSTIF_VERSION)
  9. LESSTIF_INSTALL_STAGING = YES
  10. LESSTIF_DEPENDENCIES = \
  11. xlib_libXt \
  12. xlib_libXext \
  13. freetype
  14. LESSTIF_LICENSE = LGPL-2.0+
  15. LESSTIF_LICENSE_FILES = COPYING.LIB
  16. LESSTIF_CONF_OPTS = \
  17. --with-gnu-ld \
  18. --with-freetype-config=$(STAGING_DIR)/usr/bin/freetype-config \
  19. --enable-production=yes \
  20. --enable-build-tests=no \
  21. --no-recursion
  22. # Reduces the buggy makefile to the smallest possible (and working) thing
  23. define LESSTIF_NOMAN2HTML
  24. echo "all:" > $(@D)/doc/Makefile
  25. echo "" >> $(@D)/doc/Makefile
  26. echo "install:" >> $(@D)/doc/Makefile
  27. echo "" >> $(@D)/doc/Makefile
  28. echo "clean:" >> $(@D)/doc/Makefile
  29. endef
  30. # Prevents to copy ac_find_motif.m4 on target, it would else
  31. # be created at $(TARGET_DIR)/$(HOST_DIR)/share/aclocal/ac_find_motif.m4
  32. define LESSTIF_FIXACLOCAL
  33. sed -i -e "/install-data-am: install-aclocalDATA/d" $(@D)/scripts/autoconf/Makefile
  34. endef
  35. LESSTIF_POST_CONFIGURE_HOOKS += LESSTIF_NOMAN2HTML
  36. LESSTIF_POST_CONFIGURE_HOOKS += LESSTIF_FIXACLOCAL
  37. $(eval $(autotools-package))