jq.mk 1.1 KB

12345678910111213141516171819202122232425262728293031323334
  1. ################################################################################
  2. #
  3. # jq
  4. #
  5. ################################################################################
  6. JQ_VERSION = a17dd3248a666d01be75f6b16be37e80e20b0954
  7. JQ_SITE = $(call github,stedolan,jq,$(JQ_VERSION))
  8. JQ_LICENSE = MIT (code), ICU (decNumber), CC-BY-3.0 (documentation)
  9. JQ_LICENSE_FILES = COPYING
  10. JQ_INSTALL_STAGING = YES
  11. # currently using git version directly
  12. JQ_AUTORECONF = YES
  13. # uses c99 specific features
  14. # _GNU_SOURCE added to fix gcc6+ host compilation
  15. # (https://github.com/stedolan/jq/issues/1598)
  16. JQ_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -std=c99 -D_GNU_SOURCE"
  17. HOST_JQ_CONF_ENV += CFLAGS="$(HOST_CFLAGS) -std=c99 -D_GNU_SOURCE"
  18. # jq explicitly enables maintainer mode, which we don't need/want
  19. JQ_CONF_OPTS += --disable-maintainer-mode
  20. HOST_JQ_CONF_OPTS += --disable-maintainer-mode --without-oniguruma
  21. ifeq ($(BR2_PACKAGE_ONIGURUMA),y)
  22. JQ_DEPENDENCIES += oniguruma
  23. JQ_CONF_OPTS += --with-oniguruma
  24. else
  25. JQ_CONF_OPTS += --without-oniguruma
  26. endif
  27. $(eval $(autotools-package))
  28. $(eval $(host-autotools-package))