joe.mk 648 B

12345678910111213141516171819202122232425
  1. ################################################################################
  2. #
  3. # joe
  4. #
  5. ################################################################################
  6. JOE_VERSION = 4.6
  7. JOE_SITE = http://downloads.sourceforge.net/project/joe-editor/JOE%20sources/joe-$(JOE_VERSION)
  8. JOE_LICENSE = GPL-2.0+
  9. JOE_LICENSE_FILES = COPYING
  10. ifeq ($(BR2_PACKAGE_NCURSES),y)
  11. JOE_DEPENDENCIES += ncurses
  12. JOE_CONF_OPTS += --enable-curses
  13. else
  14. JOE_CONF_OPTS += --disable-curses
  15. endif
  16. ifneq ($(BR2_PACKAGE_JOE_FULL),y)
  17. define JOE_INSTALL_TARGET_CMDS
  18. $(INSTALL) -m 0755 -D $(@D)/joe/joe $(TARGET_DIR)/usr/bin/joe
  19. endef
  20. endif
  21. $(eval $(autotools-package))