janus-gateway.mk 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129
  1. ################################################################################
  2. #
  3. # janus-gateway
  4. #
  5. ################################################################################
  6. JANUS_GATEWAY_VERSION = 0.10.3
  7. JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,v$(JANUS_GATEWAY_VERSION))
  8. JANUS_GATEWAY_LICENSE = GPL-3.0 with OpenSSL exception
  9. JANUS_GATEWAY_LICENSE_FILES = COPYING
  10. # ding-libs provides the ini_config library
  11. JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
  12. libsrtp host-gengetopt libglib2 openssl libconfig \
  13. $(if $(BR2_PACKAGE_LIBOGG),libogg)
  14. # Straight out of the repository, no ./configure, and we also patch
  15. # configure.ac.
  16. JANUS_GATEWAY_AUTORECONF = YES
  17. JANUS_GATEWAY_CONF_OPTS = \
  18. --disable-data-channels \
  19. --disable-sample-event-handler
  20. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_DEMOS),)
  21. define JANUS_GATEWAY_REMOVE_DEMOS
  22. $(RM) -fr $(TARGET_DIR)/usr/share/janus/demos/
  23. endef
  24. JANUS_GATEWAY_POST_INSTALL_TARGET_HOOKS += JANUS_GATEWAY_REMOVE_DEMOS
  25. endif
  26. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_AUDIO_BRIDGE),y)
  27. JANUS_GATEWAY_DEPENDENCIES += opus
  28. JANUS_GATEWAY_CONF_OPTS += --enable-plugin-audiobridge
  29. else
  30. JANUS_GATEWAY_CONF_OPTS += --disable-plugin-audiobridge
  31. endif
  32. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_ECHO_TEST),y)
  33. JANUS_GATEWAY_CONF_OPTS += --enable-plugin-echotest
  34. else
  35. JANUS_GATEWAY_CONF_OPTS += --disable-plugin-echotest
  36. endif
  37. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_RECORDPLAY),y)
  38. JANUS_GATEWAY_CONF_OPTS += --enable-plugin-recordplay
  39. else
  40. JANUS_GATEWAY_CONF_OPTS += --disable-plugin-recordplay
  41. endif
  42. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_SIP_GATEWAY),y)
  43. JANUS_GATEWAY_DEPENDENCIES += sofia-sip
  44. JANUS_GATEWAY_CONF_OPTS += --enable-plugin-sip
  45. else
  46. JANUS_GATEWAY_CONF_OPTS += --disable-plugin-sip
  47. endif
  48. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_STREAMING),y)
  49. JANUS_GATEWAY_CONF_OPTS += --enable-plugin-streaming
  50. else
  51. JANUS_GATEWAY_CONF_OPTS += --disable-plugin-streaming
  52. endif
  53. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_TEXT_ROOM),y)
  54. JANUS_GATEWAY_CONF_OPTS += --enable-plugin-textroom
  55. else
  56. JANUS_GATEWAY_CONF_OPTS += --disable-plugin-textroom
  57. endif
  58. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_VIDEO_CALL),y)
  59. JANUS_GATEWAY_CONF_OPTS += --enable-plugin-videocall
  60. else
  61. JANUS_GATEWAY_CONF_OPTS += --disable-plugin-videocall
  62. endif
  63. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_VIDEO_ROOM),y)
  64. JANUS_GATEWAY_CONF_OPTS += --enable-plugin-videoroom
  65. else
  66. JANUS_GATEWAY_CONF_OPTS += --disable-plugin-videoroom
  67. endif
  68. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_VOICE_MAIL),y)
  69. JANUS_GATEWAY_CONF_OPTS += --enable-plugin-voicemail
  70. else
  71. JANUS_GATEWAY_CONF_OPTS += --disable-plugin-voicemail
  72. endif
  73. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_MQTT),y)
  74. JANUS_GATEWAY_DEPENDENCIES += paho-mqtt-c
  75. JANUS_GATEWAY_CONF_OPTS += --enable-mqtt
  76. else
  77. JANUS_GATEWAY_CONF_OPTS += --disable-mqtt
  78. endif
  79. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_RABBITMQ),y)
  80. JANUS_GATEWAY_DEPENDENCIES += rabbitmq-c
  81. JANUS_GATEWAY_CONF_OPTS += --enable-rabbitmq
  82. else
  83. JANUS_GATEWAY_CONF_OPTS += --disable-rabbitmq
  84. endif
  85. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_REST),y)
  86. JANUS_GATEWAY_DEPENDENCIES += libmicrohttpd
  87. JANUS_GATEWAY_CONF_OPTS += --enable-rest
  88. else
  89. JANUS_GATEWAY_CONF_OPTS += --disable-rest
  90. endif
  91. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_UNIX_SOCKETS),y)
  92. JANUS_GATEWAY_CONF_OPTS += --enable-unix-sockets
  93. else
  94. JANUS_GATEWAY_CONF_OPTS += --disable-unix-sockets
  95. endif
  96. ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_WEBSOCKETS),y)
  97. JANUS_GATEWAY_DEPENDENCIES += libwebsockets
  98. JANUS_GATEWAY_CONF_OPTS += --enable-websockets
  99. else
  100. JANUS_GATEWAY_CONF_OPTS += --disable-websockets
  101. endif
  102. ifeq ($(BR2_PACKAGE_SYSTEMD),y)
  103. JANUS_GATEWAY_DEPENDENCIES += systemd
  104. JANUS_GATEWAY_CONF_OPTS += --enable-systemd-sockets
  105. else
  106. JANUS_GATEWAY_CONF_OPTS += --disable-systemd-sockets
  107. endif
  108. $(eval $(autotools-package))